dotNET 手动移植文档

操作步骤

  1. 用 Visual Studio（2015 或更高版本）打开项目，修改目标框架为 .NET Framework 4.7。

  2. 在引用一栏，把“accore.dll”，“acdbmgd.dll”和“acmgd.dll”替换成 ZWCAD 安装目录下的“ZwDatabaseMgd.dll”和“ZwManaged.dll”。

    把 ZwDatabaseMgd 和 ZwManaged 的“复制到本地”属性改为 false。

  3. 如果您的程序引用了“Autodesk.AutoCAD.Interop”和“Autodesk.AutoCAD.Interop.Common”，请替换成“ZWCAD.exe”。

  4. 把代码中所有的“Autodesk.AutoCAD.Interop”和“Autodesk.AutoCAD.Interop.Common”命名空间改成“ZWCAD”，所有“Autodesk.AutoCAD.xxxx”命名空间改为“ZwSoft.ZwCAD.xxxx”。

  5. 把使用到名字为 Acadxxxx（例如， AcadLine）的对象改为 Zcadxxxx。

  6. 然后您可以重新编译工程，并在 ZWCAD 中加载生成的 dll 文件。